Closed Bug 1149430 Opened 5 years ago Closed 4 years ago

No more dev edition theme on nightly

Categories

(Firefox :: Developer Tools, defect)

40 Branch
x86
Mac OS X
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: m+bugzilla, Unassigned)

References

Details

Attachments

(1 file)

Attached image screenshot 2015-03-31 at 10.43.30.png (deleted) —
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150330114816

Steps to reproduce:

The dev edition theme isn't available anymore. Even if you click on the button.



Expected results:

It should works! :)

Oh and by the way. Yesterday, the dev edition theme was available via the theme list, which is was cool. A button to active it isn't a good idea in my opinion.
Component: Untriaged → Developer Tools
The theme work was temporarily backed out.  It will be relanded in bug 1148996.
Depends on: 1148996
Thank you jryans.
(In reply to Erwann Mest from comment #0)
> Created attachment 8585945 [details]
> screenshot 2015-03-31 at 10.43.30.png
> 
> User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:40.0)
> Gecko/20100101 Firefox/40.0
> Build ID: 20150330114816
> 
> Steps to reproduce:
> 
> The dev edition theme isn't available anymore. Even if you click on the
> button.
> 

Is the button not visible at all?  That pref could have been cleared out after you pulled down the updated version.  You may need to set browser.devedition.theme.showCustomizeButton = true and then restart the browser to get it to show back up.  Hopefully it will be back in the addon manager soon.
- 2 or 3 versions ago, it wasn't a button but a theme listed in "themes": new feature, good point
- now, it comes back as a button ("use dev edition theme"): regression in my point of view
- `browser.devedition.theme.showCustomizeButton` is already as true
- `browser.devedition.theme.enabled` also as true
(In reply to Erwann Mest from comment #4)
> - 2 or 3 versions ago, it wasn't a button but a theme listed in "themes":
> new feature, good point
> - now, it comes back as a button ("use dev edition theme"): regression in my
> point of view
> - `browser.devedition.theme.showCustomizeButton` is already as true
> - `browser.devedition.theme.enabled` also as true

OK, so the button is working then?  I took the wording in the description to mean that the button didn't work.  The button will go away again once Bug 1148996 lands.
The button works and changes `browser.devedition.theme.enabled` property but nothing appears about firefox theming.
In other words, I am currently with the default firefox theme. I don't/can't have dev edition theme.
(In reply to Erwann Mest from comment #7)
> In other words, I am currently with the default firefox theme. I don't/can't
> have dev edition theme.

Oh, that's probably because still you have a lightweight theme ID selected (the devedition theme).  Can you try resetting the lightweightThemes.selectedThemeID pref?
`lightweightThemes.selectedThemeID;firefox-devedition@mozilla.org` -> reset

Oh my gooooooooooooooood, it works ^^

Thank you Brian. ;)
It works pretty good now, thank you. :)
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.