Closed Bug 410170 Opened 12 years ago Closed 3 years ago

Selecting Quit from Dock while modal dialog (sheet) is displayed does not close the Application

Categories

(Core :: Widget: Cocoa, defect, P2)

x86
Mac OS X
defect

Tracking

()

RESOLVED INVALID

People

(Reporter: whimboo, Unassigned)

Details

(Keywords: regression, Whiteboard: tpi:+)

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b3pre) Gecko/2007122904 Minefield/3.0b3pre

While trying to verify bug 355273 I noticed that it is not possible to close the application (Firefox and Thunderbird) from the dock while a modal dialog (sheet) is displayed. There is only played the beep. This was working with Firefox 2.

Could this be a regression from switching to Cocoa?

I put this bug into Widgets:Mac. If this is not the right component please update.
"Widget: Cocoa" is better :-)
Component: Widget: Mac → Widget: Cocoa
QA Contact: mac → cocoa
1) Is this really a bug?

Some modal dialogs disable "Minefield : Quit Minefield" (e.g. "File :
Open File" or "File : Save Page As").  And in any case, shouldn't you
have to at least cancel out of the modal dialog before doing anything
else?

2) And which kind of modal dialog?

Some modal dialogs (e.g. "File : Open File") disable "Minefield : Quit
Minefield" and others don't (e.g. the "Confirm Close" modal dialog you
get when you try to close a window containing more than one tab).

Both behave the same way when you try to Quit from the Dock menu (the
Quit command is simply ignored -- which I think is correct).

But you get strange behavior when you choose "Minefield : Quit
Minefield" while the "Confirm Close" modal dialog is open (on the
trunk but not on the 1.8 branch).  I'll open a bug about this in the
not too distant future.
(In reply to comment #2)
> 1) Is this really a bug?

I think yes. I'm still able to quit Minefield using the main menu. This menu item isn't deactivated. But I cannot quit Minefield over the dock. 

> 2) And which kind of modal dialog?

Open a javascript alert or the Master Password dialog. These are just two examples where it happens.

> But you get strange behavior when you choose "Minefield : Quit
> Minefield" while the "Confirm Close" modal dialog is open (on the
> trunk but not on the 1.8 branch).  I'll open a bug about this in the
> not too distant future.

Can you CC me please?
Bug 395465 is on my to-do list, and fixing it may well change the
behavior reported here:

Fixing bug 395465 may require that all modal sheets be changed into
modal windows, and (as best I can tell) modal non-sheet windows always
disable Quit in the application's main menu.  If so, it will then
always be correct to ignore a Quit from the Dock menu while a modal
window is open.

I'm tentatively assigning this bug to myself ... though I won't get to
it for a while.  I'm also going to hold off on opening a new bug about
the "strange behavior" I reported in comment #2 -- since that, too,
may get changed (or fixed) by a fix for bug 395465.
Assignee: joshmoz → smichaud
This should be one of the problems dealt with in bug 478073.
This bug probably still happens.  But I almost certainly never will have time to do any more work on it.
Assignee: smichaud → nobody
Hi,

I have tested on Mac OS X 10.10 with FF Nightly 48.0a1 and I can't reproduce it. Henrik when you have time can you retest this with the latest FF version to see if you can reproduce it? 

Thanks.
It's still happening as given by my example in comment 3. So not sure what you tested.
I have retested with the examples from comment 3 and I can reproduce. I am not sure but I think this is the expected behaviour.
Whiteboard: tpi:p4
Priority: -- → P2
Whiteboard: tpi:p4 → tpi:+
This seems to be the expected behavior. If this is still believed to be a bug, please reopen with comparisons to other applications (such as Safari) that behave differently.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.