Closed Bug 919040 Opened 7 years ago Closed 3 years ago

all Turublenz demos fail with r.gain is not defined

Categories

(Tech Evangelism :: Desktop, defect)

x86_64
Windows 8
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: vlad, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [games:p?] [country-us] [sitewait] [js] [audio])

I'm guessing this is a Web Audio thing.

https://turbulenz.com/#
https://turbulenz.com/games/denkiblocks/play

anything in their gallery; all eventually stop loading.  This might be an evang thing, but we can also submit a patch to them.
The js debugger shows that the games are using the deprecated (and not implemented by us anymore) .gain attribute of the AudioBufferSourceNode object.

Ehsan and I have put together a porting guide for people that have to update their code bases to work with the standard AudioContext [1]. Specifically, the (easy) steps to fix this particular issue are explained at [2].

Since their source is minified, I'm not sure submitting a patch to them makes much sense, but we should certainly contact them, this is an easy fix, and other UA (unlikely for Safari, not sure about a specific timeline for Chrome) will eventually drop non-standard Web Audio API features, so they will break.

[1]: https://developer.mozilla.org/en-US/docs/Web_Audio_API/Porting_webkitAudioContext_code_to_standards_based_AudioContext
[2]: https://developer.mozilla.org/en-US/docs/Web_Audio_API/Porting_webkitAudioContext_code_to_standards_based_AudioContext#Removal_of_AudioBufferSourceNode.gain
I have contacted them and provided them with a link to this bug.
This is kind of a dupe of bug 861591, but what happened there is that we ended up implementing AudioBufferSourceNode.gain and then removed it when Chris Rogers agreed to drop that attribute (but I don't think the Blink change ever happened.)  And somewhere in this back and forth I contacted Turbulenz about this and asked them to fix their code and never heard back.

So, in short, this is known, and there is nothing that we can do about it on our side.
Assignee: nobody → english-us
Component: Web Audio → English US
Product: Core → Tech Evangelism
Now we are redirected to https://ga.me/games/denkiblocks
It is still not working.

It doesn't work in Safari Version 7.1 (9537.85.10.17.1).
They ask to download Chrome or Firefox or to activate the dev menu for WebGL. Once activated in Safari it is working.

The screen is black and doesn't display anything.
Assignee: english-us → nobody
Component: English US → Desktop
Whiteboard: [games:p2] → [games:p2] [country-us] [sitewait] [js] [audio]
Whiteboard: [games:p2] [country-us] [sitewait] [js] [audio] → [games:p?] [country-us] [sitewait] [js] [audio]
The game is working for me now.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.